summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-02 19:58:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:18 +0300
commit2460d877f3b2027d7b1c75fcc5c9863adf8a2a9f (patch)
treeabb1e4efa3380c6f05972a46ba7354bf3a25e8c9 /gnu
parent26c44890dc9c2e4b509a123f1cb13c1655a26677 (diff)
downloadguix-2460d877f3b2027d7b1c75fcc5c9863adf8a2a9f.tar.gz
gnu: Add rust-ntest-timeout-0.9.
* gnu/packages/crates-io.scm (rust-ntest-timeout-0.9): New variable.
(rust-ntest-timeout-0.8): Inherit from rust-ntest-timeout-0.9.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 26 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ee332b1046..0536ffb944 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41442,8 +41442,33 @@ enhances the built-in library with some useful features.")
         ("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))))
 
+(define-public rust-ntest-timeout-0.9
+  (package
+    (name "rust-ntest-timeout")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "ntest-timeout" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1948a5ps329acg8fy2c2dyjgc8f96l0gin271cpl0yjq420lcsq6"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-proc-macro-crate" ,rust-proc-macro-crate-1)
+        ("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/becheran/ntest")
+    (synopsis "Timeout attribute for the ntest framework")
+    (description "This package provides a timeout attribute for the ntest
+framework.")
+    (license license:expat)))
+
 (define-public rust-ntest-timeout-0.8
   (package
+    (inherit rust-ntest-timeout-0.9)
     (name "rust-ntest-timeout")
     (version "0.8.1")
     (source
@@ -41453,19 +41478,13 @@ enhances the built-in library with some useful features.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "01vcdlz9xj471z5knk2qynm7adz3p614glf6n0pgn161qynym9mw"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-ntest-proc-macro-helper" ,rust-ntest-proc-macro-helper-0.8)
         ("rust-proc-macro-crate" ,rust-proc-macro-crate-1)
         ("rust-proc-macro2" ,rust-proc-macro2-1)
         ("rust-quote" ,rust-quote-1)
-        ("rust-syn" ,rust-syn-1))))
-    (home-page "https://github.com/becheran/ntest")
-    (synopsis "Timeout attribute for the ntest framework")
-    (description "This package provides a timeout attribute for the ntest
-framework.")
-    (license license:expat)))
+        ("rust-syn" ,rust-syn-1))))))
 
 (define-public rust-ntest-proc-macro-helper-0.8
   (package