summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-12-11 01:00:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-12-11 01:00:00 +0100
commit2472015c36f333657c5a223150e3e809f01ad1af (patch)
tree2dab53b572fdcae9efcedbbbc0e35dae9103a881 /gnu
parent0335499876d08b12c63057f386535695f1b65597 (diff)
downloadguix-2472015c36f333657c5a223150e3e809f01ad1af.tar.gz
gnu: ecryptfs-utils: Remove input labels.
* gnu/packages/linux.scm (ecryptfs-utils)[inputs]:
Remove input labels.
[arguments]: Fix ‘utils-linux’ typo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f8b29d4d46..41fb24f82a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6773,7 +6773,7 @@ not as a replacement for it.")
          (add-after 'patch-source-shebangs 'patch-hardcoded-paths
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
-                   (utils-linux (assoc-ref inputs "utils-linux"))
+                   (util-linux (assoc-ref inputs "util-linux"))
                    (cryptsetup (assoc-ref inputs "cryptsetup"))
                    (linux-pam (assoc-ref inputs "linux-pam"))
                    (lvm2 (assoc-ref inputs "lvm2")))
@@ -6787,9 +6787,9 @@ not as a replacement for it.")
                               "src/desktop/ecryptfs-mount-private.desktop.in"
                               "src/desktop/ecryptfs-setup-private.desktop.in")
                  (("/bin/mount")
-                  (string-append utils-linux "/bin/mount"))
+                  (string-append util-linux "/bin/mount"))
                  (("/bin/umount")
-                  (string-append utils-linux "/bin/umount"))
+                  (string-append util-linux "/bin/umount"))
                  (("/sbin/mount.ecryptfs_private")
                   (string-append out "/sbin/mount.ecryptfs_private"))
                  (("/sbin/umount.ecryptfs_private")
@@ -6833,20 +6833,20 @@ not as a replacement for it.")
      (list intltool perl ; for pod2man
            pkg-config))
     (inputs
-     `(("coreutils" ,coreutils)
-       ("findutils" ,findutils)
-       ("gawk" ,gawk)
-       ("grep" ,grep)
-       ("keyutils" ,keyutils)
-       ("linux-pam" ,linux-pam)
-       ("lsof" ,lsof)
-       ("utils-linux" ,util-linux)
-       ("cryptsetup" ,cryptsetup)
-       ("lvm2" ,lvm2)
-       ("nss" ,nss)
-       ("rsync", rsync)
-       ("sed" ,sed)
-       ("which" ,which)))
+     (list coreutils
+           cryptsetup
+           findutils
+           gawk
+           grep
+           keyutils
+           linux-pam
+           lsof
+           lvm2
+           nss
+           rsync
+           sed
+           util-linux
+           which))
     (home-page "https://ecryptfs.org/")
     (synopsis "eCryptfs cryptographic file system utilities")
     (description