summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-04-10 21:21:06 -0700
committerLeo Famulari <leo@famulari.name>2020-05-29 10:44:33 -0400
commit2496e49f85b59d1b95e720344d4cd5dcc08f4aa3 (patch)
tree9ecf3ae4efb3aec44e1a89e574e20418f372874e /gnu
parent6c0858dda26dc1d3af8e546d9b1fda59175da9a0 (diff)
downloadguix-2496e49f85b59d1b95e720344d4cd5dcc08f4aa3.tar.gz
gnu: Add ghc-prettyprinter-1.6.
* gnu/packages/haskell-xyz.scm (ghc-prettyprinter-1.6): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 30a09bde8b..6ec349e575 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9516,6 +9516,23 @@ ANSI terminal backend exists, HTML backend is trivial to implement, no name
 clashes, @code{Text}-based, extensible.")
     (license license:bsd-2)))
 
+(define-public ghc-prettyprinter-1.6
+  (package
+    (inherit ghc-prettyprinter)
+    (version "1.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://hackage/package/prettyprinter/prettyprinter-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32 "10fphxh8lvdaw7i8jyllwmj87w02db92mf99zfw5vddp9mv6b5rz"))))
+    (inputs
+     `(("ghc-quickckeck-instances" , ghc-quickcheck-instances)
+       ,@(package-inputs ghc-prettyprinter)))))
+
 (define-public ghc-pretty-hex
   (package
     (name "ghc-pretty-hex")