summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 09:43:19 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:35 +0200
commit24a2aaf3ff04232fe9c23bb0a9da2a93324a0ab3 (patch)
tree7d0c929793642808f8a3e2e21a87f46dd6e2c0db /gnu
parentd4bd5c60daa70f14fccb8789091e5a3f85b4f7dc (diff)
downloadguix-24a2aaf3ff04232fe9c23bb0a9da2a93324a0ab3.tar.gz
gnu: Add lksctp-tools.
* gnu/packages/networking.scm (lksctp-tools): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 059f78a0d0..13974ead4a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -133,6 +133,41 @@
   #:use-module (gnu packages xml)
   #:use-module (ice-9 match))
 
+(define-public lksctp-tools
+  (package
+    (name "lksctp-tools")
+    (version "1.0.18")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/sctp/lksctp-tools.git")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1x4fwzrlzvfa3vcpja97m8w5g9ir2zrh4zs7zksminrnmdrs0dsr"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("linux-headers" ,linux-libre-headers)))
+    (synopsis "Linux SCTP helper library")
+    (description "Lksctp-tools project provides a user space library for SCTP
+(libsctp) including C language header files (netinet/sctp.h) for accessing SCTP
+specific application programming interfaces not provided by the standard
+sockets, and also some helper utilities around SCTP.")
+    (home-page "http://lksctp.sourceforge.net/")
+    (license
+     (list
+      ;; Library.
+      license:lgpl2.1+
+      ;; Others.
+      license:gpl2+))))
+
 (define-public nng
   (package
     (name "nng")