summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-30 22:32:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:32:46 +0200
commit2513aac170781d2bbd0b8406cc425d9ce7cb9de4 (patch)
treec7c5368f319db02d91f7ff2291b606ac102b9220 /gnu
parent4951d2f386dc5da9569a0de14e9e98009af7b3d2 (diff)
downloadguix-2513aac170781d2bbd0b8406cc425d9ce7cb9de4.tar.gz
gnu: kodi: Update to 18.0_alpha-1-ec5d53d.
* gnu/packages/kodi.scm (kodi): Update to 18.0_alpha-1-ec5d53d.
[inputs]: Replace LIBYAJL with RAPIDJSON.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kodi.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index 52e49a94f0..b5d86b5636 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -239,8 +239,8 @@ generator library for C++.")
 (define-public kodi
   ;; We package the git version because the current released
   ;; version was cut while the cmake transition was in turmoil.
-  (let ((commit "b35147e2bec41ce332b9788f4a6ac94d2e5999e3")
-        (revision "0"))
+  (let ((commit "ec5d53da72868ad37df8bc005452a6daaa20f20b")
+        (revision "1"))
   (package
     (name "kodi")
     (version (string-append "18.0_alpha-" revision "-" (string-take commit 7)))
@@ -252,7 +252,7 @@ generator library for C++.")
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0rhb9rcz5h8mky8mx6idzybnpgjh2lxcjkh16z1x6fr4pis2jcbj"))
+                "05f0bip0w784ya72plw3p2bism5m501q07si2xbmg03vhqsagjl5"))
               (snippet
                '(begin
                   (use-modules (guix build utils))
@@ -401,13 +401,13 @@ generator library for C++.")
        ("libxrandr" ,libxrandr)
        ("libxrender" ,libxrender)
        ("libxslt" ,libxslt)
-       ("libyajl" ,libyajl)
        ("lzo" ,lzo)
        ("mysql" ,mysql)
        ("openssl" ,openssl)
        ("pcre" ,pcre)
        ("pulseaudio" ,pulseaudio)
        ("python" ,python-2)
+       ("rapidjson" ,rapidjson)
        ("samba" ,samba)
        ("sqlite" ,sqlite)
        ("taglib" ,taglib)