summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-07 19:13:46 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-07 19:13:46 +0200
commit25352fe10608d68053f41f0bcaa7571f1432fd14 (patch)
tree8c99231cdc52c7cfd49fe0dc55ab40578c3b5854 /gnu
parent6bfc16d93c04f4be2ef53a5fe271d8898a02fda8 (diff)
downloadguix-25352fe10608d68053f41f0bcaa7571f1432fd14.tar.gz
gnu: Add ripperX.
* gnu/packages/mp3.scm (ripperx): New variable.
* gnu/packages/patches/ripperx-libm.patch: New file.
* gnu-system.am (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mp3.scm43
-rw-r--r--gnu/packages/patches/ripperx-libm.patch12
2 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 941fc47ecd..ee7f938e45 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -19,8 +19,13 @@
 (define-module (gnu packages mp3)
   #:use-module ((guix licenses)
                 #:renamer (symbol-prefix-proc 'license:))
+  #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages cdrom)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages oggvorbis)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
@@ -222,3 +227,41 @@ use with CD-recording software).")
     (synopsis "MPEG Audio Layer III (MP3) encoder")
     (description "LAME is a high quality MPEG Audio Layer III (MP3) encoder.")
     (license license:lgpl2.0)))
+
+(define-public ripperx
+  (package
+   (name "ripperx")
+   (version "2.7.3")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://sourceforge/ripperx/ripperx/"
+                                version "/ripperX-"
+                                version ".tar.gz"))
+            (sha256
+             (base32
+              "130rsb2ly0l6hz728m9qr605ir4073xfl2acvf83id63kxfzjn3x"))))
+   (build-system gnu-build-system)
+   (propagated-inputs
+    `(("gs-fonts" ,gs-fonts)
+      ("cdparanoia" ,cdparanoia)
+      ("flac" ,flac)
+      ("lame" ,lame)
+      ("vorbis-tools" ,vorbis-tools)))
+   (inputs
+    `(("patch/libm" ,(search-patch "ripperx-libm.patch"))
+      ("glib" ,glib)
+      ("gtk+" ,gtk+)
+      ("id3lib" ,id3lib)
+      ("pkg-config" ,pkg-config)))
+   (arguments
+    `(#:patches
+      ;; see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713684
+      (list (assoc-ref %build-inputs "patch/libm"))))
+   (synopsis "GTK program to rip and encode CD audio tracks")
+   (description
+    "RipperX is a GTK program to rip CD audio tracks and encode them to the
+Ogg, MP3, or FLAC formats. It's goal is to be easy to use, requiring only
+a few mouse clicks to convert an entire album. It supports CDDB lookups
+for album and track information.")
+   (license license:gpl2)
+   (home-page "http://sourceforge.net/projects/ripperx/")))
diff --git a/gnu/packages/patches/ripperx-libm.patch b/gnu/packages/patches/ripperx-libm.patch
new file mode 100644
index 0000000000..48277077cf
--- /dev/null
+++ b/gnu/packages/patches/ripperx-libm.patch
@@ -0,0 +1,12 @@
+diff -r -u ripperX-2.7.3.old/src/Makefile.in ripperX-2.7.3.new/src/Makefile.in
+--- ripperX-2.7.3.old/src/Makefile.in	2008-01-25 10:53:50.000000000 +0100
++++ ripperX-2.7.3.new/src/Makefile.in	2013-08-07 16:14:21.000000000 +0200
+@@ -43,7 +43,7 @@
+ 
+ ripperX_LDADD = \
+ 	$(INTLLIBS) \
+-	$(GTK_LIBS)
++	$(GTK_LIBS) -lm
+ 
+ AM_CPPFLAGS = \
+ 	-DG_LOG_DOMAIN=\"ripperX\" \