summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-15 18:47:08 +0100
committerLudovic Courtès <ludo@gnu.org>2023-10-21 16:07:58 +0200
commit25555c98209c84be142addc61f270e7c82405317 (patch)
tree2785659f10807ad0361a7197c940eac3310fd131 /gnu
parentae2f075716cfb2b53a55b1a3f26d382420fb036a (diff)
downloadguix-25555c98209c84be142addc61f270e7c82405317.tar.gz
gnu: Remove emacs-poke.
This naming conflicts with the ELPA 'poke' package, a emacs interface to
GNU poke.

* gnu/packages/engineering.scm (emacs-poke): Turn into a deprecated
alias for “poke”.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index e478b8364d..b43e058af4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3277,22 +3277,9 @@ data structures and to operate on them.")
     (license license:gpl3+)))
 
 (define-public emacs-poke
-  (package
-    (inherit poke)
-    (name "emacs-poke")
-    (build-system emacs-build-system)
-    (arguments
-     (list
-       #:phases
-       #~(modify-phases %standard-phases
-           (add-before 'expand-load-path 'change-working-directory
-             (lambda _ (chdir "etc"))))))
-    (inputs '())
-    (native-inputs '())
-    (synopsis "GNU Poke major modes for Emacs")
-    (description
-     "This package provides two Emacs major modes for working with GNU Poke:
-@code{Poke Ras mode} and @code{Poke Map mode}.")))
+  ;; The 'emacs-poke' name may eventually refer to 'poke' from ELPA, which is
+  ;; a different beast.
+  (deprecated-package "emacs-poke" poke))
 
 (define-public pcb2gcode
   (package