summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 19:07:44 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:17 +0100
commit255f1cae42edce0b06a068b4d7134e2cef1c514b (patch)
tree7bd5c310837c89a93486ac0331be0cc5cd94b084 /gnu
parent7bd4b85e9bbb70687129721c9bdb2cf0576c715c (diff)
downloadguix-255f1cae42edce0b06a068b4d7134e2cef1c514b.tar.gz
gnu: Add ocaml-ppx-jane.
* gnu/packages/ocaml.scm (ocaml-ppx-jane): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cbcb225c78..686be3cb59 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5903,3 +5903,46 @@ verification tool.")
     (description "Generation of binary serialization and deserialization
 functions from type definitions.")
     (license license:asl2.0)))
+
+(define-public ocaml-ppx-jane
+  (package
+    (name "ocaml-ppx-jane")
+    (version "0.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+                                  (version-major+minor version)
+                                  "/files/ppx_jane-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "0lgppkw3aixrfnixihrsz2ipafv8fpvkdpy3pw8n0r615gg8x8la"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:test-target "."))
+    (propagated-inputs
+      `(("ocaml-ppx-assert" ,ocaml-ppx-assert)
+        ("ocaml-ppx-base" ,ocaml-ppx-base)
+        ("ocaml-ppx-bench" ,ocaml-ppx-bench)
+        ("ocaml-ppx-bin-prot" ,ocaml-ppx-bin-prot)
+        ("ocaml-ppx-custom-printf" ,ocaml-ppx-custom-printf)
+        ("ocaml-ppx-expect" ,ocaml-ppx-expect)
+        ("ocaml-ppx-fail" ,ocaml-ppx-fail)
+        ("ocaml-ppx-fields-conv" ,ocaml-ppx-fields-conv)
+        ("ocaml-ppx-here" ,ocaml-ppx-here)
+        ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
+        ("ocaml-ppx-let" ,ocaml-ppx-let)
+        ("ocaml-ppx-optcomp" ,ocaml-ppx-optcomp)
+        ("ocaml-ppx-optional" ,ocaml-ppx-optional)
+        ("ocaml-ppx-pipebang" ,ocaml-ppx-pipebang)
+        ("ocaml-ppx-sexp-message" ,ocaml-ppx-sexp-message)
+        ("ocaml-ppx-sexp-value" ,ocaml-ppx-sexp-value)
+        ("ocaml-ppx-typerep-conv" ,ocaml-ppx-typerep-conv)
+        ("ocaml-ppx-variants-conv" ,ocaml-ppx-variants-conv)
+        ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+        ("ocaml-ppxlib" ,ocaml-ppxlib)))
+    (properties `((upstream-name . "ppx_jane")))
+    (home-page "https://github.com/janestreet/ppx_jane")
+    (synopsis "Standard Jane Street ppx rewriters")
+    (description "This package installs a ppx-jane executable, which is a ppx
+driver including all standard Jane Street ppx rewriters.")
+    (license license:asl2.0)))