summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-13 16:14:40 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 00:06:12 -0400
commit261a1f902a63c8d9a0599affbdcf4715330bb9a9 (patch)
tree891b23707f0c42ee40c62057047f7e63819299f6 /gnu
parent431d64bae2c54fe3200f8f69d83f6e8fd0675eec (diff)
downloadguix-261a1f902a63c8d9a0599affbdcf4715330bb9a9.tar.gz
gnu: qmk: Use GCC 8 for the AVR toolchain.
* gnu/packages/firmware.scm (qmk) [inputs]: Specify 'gcc-8' as the #:xgcc
argument to the 'make-avr-toolchain' procedure.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 499920160a..c1f6c8ea5e 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1257,7 +1257,9 @@ AR100.")
     ;; The inputs are not propagated since qmk is to be used strictly as a
     ;; command.
     (inputs
-     (list (make-avr-toolchain)
+     ;; The 'qmk setup' command advises to use GCC at version 8, and there are
+     ;; compilation errors in some firmware otherwise.
+     (list (make-avr-toolchain #:xgcc gcc-8)
            avrdude
            dfu-programmer
            git-minimal                  ;for the clone action