summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-17 00:16:43 -0400
committerMark H Weaver <mhw@netris.org>2018-03-17 00:19:40 -0400
commit2857e527de058d9e7f4efea50d381a449a1b6641 (patch)
tree60f16a2481503df387641dfc918cba6caae6ea88 /gnu
parent99aaeaa00bd3d5964fc5a723f52c2baf3f3d2974 (diff)
downloadguix-2857e527de058d9e7f4efea50d381a449a1b6641.tar.gz
gnu: Fix a few more snippets to return #t.
This is a followup to commit 6cbee49d6668eb7fd738080666f66febfce8c7e8.

* gnu/packages/video.scm (mlt, livemedia-utils)[source]
gnu/packages/web.scm (goaccess, httptunnel)[source]: Return #t from snippets.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm6
-rw-r--r--gnu/packages/web.scm6
2 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 41d15558f0..f900eeeb6f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1798,7 +1798,8 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
               (snippet '(begin
                           ;; As of glibc 2.26, <xlocale.h> no longer is.
                           (substitute* "src/framework/mlt_property.h"
-                            (("xlocale\\.h") "locale.h"))))))
+                            (("xlocale\\.h") "locale.h"))
+                          #t))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no tests
@@ -2500,7 +2501,8 @@ many codecs and formats supported by libmediainfo.")
               (snippet '(begin
                           ;; As of glibc 2.26, <xlocale.h> no longer is.
                           (substitute* "liveMedia/include/Locale.hh"
-                            (("xlocale\\.h") "locale.h"))))))
+                            (("xlocale\\.h") "locale.h"))
+                          #t))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f ; no tests
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a70db24d7b..fd631d4fd8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4841,7 +4841,8 @@ config files---you only have to specify the www root.")
               (snippet '(begin
                           (substitute* "src/error.h"
                             (("__DATE__") "\"1970-01-01\"")
-                            (("__TIME__") "\"00:00:00\""))))))
+                            (("__TIME__") "\"00:00:00\""))
+                          #t))))
     (build-system gnu-build-system)
     (inputs
      ;; TODO: Add dependency on geoip-tools.
@@ -4873,7 +4874,8 @@ on the fly.")
        (modules '((guix build utils)))
        (snippet '(begin
                    ;; Remove non-free IETF RFC documentation.
-                   (delete-file-recursively "doc")))))
+                   (delete-file-recursively "doc")
+                   #t))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases