summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2017-04-03 09:01:22 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-05-16 15:18:14 +0200
commit290bf612bb290bccf0bb93b0b34448ddee46c6ef (patch)
treeb69dff5ae3abfbafc56639360f306d72ab72c066 /gnu
parent6c76ce39ac704d002a20539598e10d091f1611b0 (diff)
downloadguix-290bf612bb290bccf0bb93b0b34448ddee46c6ef.tar.gz
gnu: cl-stumpwm: Build the library in "lib" and the program in "bin".
* gnu/packages/lisp.scm (sbcl-stumpwm)[outputs]: Remove "bin" and add "lib".
[arguments]<#:phases>: Change the target of `build-program' to the "out"
output. Likewise, change the target of the desktop file generation.
(sbcl-stumpwm+slynk)[inputs]: Use the "lib" output of sbcl-stumpwm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm28
1 files changed, 13 insertions, 15 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 6b4a177632..c395effd1c 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -853,7 +853,7 @@ from other CLXes around the net.")
     (build-system asdf-build-system/sbcl)
     (inputs `(("sbcl-cl-ppcre" ,sbcl-cl-ppcre)
               ("sbcl-clx" ,sbcl-clx)))
-    (outputs '("out" "bin"))
+    (outputs '("out" "lib"))
     (arguments
      '(#:special-dependencies '("sb-posix")
        #:phases
@@ -862,20 +862,18 @@ from other CLXes around the net.")
            (lambda* (#:key lisp outputs inputs #:allow-other-keys)
              (build-program
               lisp
-              (string-append (assoc-ref outputs "bin") "/bin/stumpwm")
+              (string-append (assoc-ref outputs "out") "/bin/stumpwm")
               #:inputs inputs
               #:entry-program '((stumpwm:stumpwm) 0))))
          (add-after 'build-program 'create-desktop-file
-           (lambda* (#:key outputs lisp binary? #:allow-other-keys)
-             (let ((output (or (assoc-ref outputs "bin")
-                               (assoc-ref outputs "out")))
-                   (xsessions "/share/xsessions"))
-               (mkdir-p (string-append output xsessions))
-               (with-output-to-file
-                   (string-append output xsessions
-                                  "/stumpwm.desktop")
-                 (lambda _
-                   (format #t
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (xsessions (string-append out "/share/xsessions")))
+               (mkdir-p xsessions)
+               (call-with-output-file
+                   (string-append xsessions "/stumpwm.desktop")
+                 (lambda (file)
+                   (format file
                     "[Desktop Entry]~@
                      Name=stumpwm~@
                      Comment=The Stump Window Manager~@
@@ -883,7 +881,7 @@ from other CLXes around the net.")
                      TryExec=~@*~a/bin/stumpwm~@
                      Icon=~@
                      Type=Application~%"
-                    output)))
+                    out)))
                #t))))))
     (synopsis "Window manager written in Common Lisp")
     (description "Stumpwm is a window manager written entirely in Common Lisp.
@@ -1143,7 +1141,7 @@ multiple inspectors with independent history.")
     (name "sbcl-stumpwm-with-slynk")
     (outputs '("out"))
     (native-inputs
-     `(("stumpwm" ,sbcl-stumpwm)
+     `(("stumpwm" ,sbcl-stumpwm "lib")
        ("slynk" ,sbcl-slynk)))
     (arguments
      (substitute-keyword-arguments (package-arguments sbcl-stumpwm)
@@ -1164,6 +1162,6 @@ multiple inspectors with independent history.")
            (delete 'copy-source)
            (delete 'build)
            (delete 'check)
-           (delete 'link-dependencies)
+           (delete 'create-asd-file)
            (delete 'cleanup)
            (delete 'create-symlinks)))))))