summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:51:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:13 +0200
commit298b085580e5fd7316c7ff45225be1188aea8bfc (patch)
tree42b5b9b627981143db4092bf6a6854a883f85fb0 /gnu
parenta386f615e03f3b1d966270fb35c4b134816986e6 (diff)
downloadguix-298b085580e5fd7316c7ff45225be1188aea8bfc.tar.gz
gnu: Add texlive-toptesi.
* gnu/packages/tex.scm (texlive-toptesi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4d2a6748c3..abd848a4f2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -29928,6 +29928,30 @@ Torino}.  The class can be used for letters written in Italian and in
 English.")
     (license license:asl2.0)))
 
+(define-public texlive-toptesi
+  (package
+    (name "texlive-toptesi")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/toptesi/" "source/latex/toptesi/"
+                   "tex/latex/toptesi/")
+             (base32
+              "0mskk7swjgcy6lw1l81brcnw7n870mrz3la64ln0f3mxps98gik6")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/toptesi")
+    (synopsis "Bundle for typesetting multilanguage theses")
+    (description
+     "This bundle contains everything needed for typesetting a bachelor,
+master, or PhD thesis in any language supported by LaTeX.  The infix strings
+may be selected and specified at will by means of a configuration file, so as
+to customize the layout of the front page to the requirements of a specific
+university.  Thanks to its language management, the bundle is suited for
+multi-language theses.  Toptesi is designed to save the PDF version of
+a thesis in PDF/A-1b compliant mode and with all the necessary metadata.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-tpslifonts
   (package
     (name "texlive-tpslifonts")