summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:24 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:31:58 -0500
commit29b0fc4cdaf8d215b83dddbb98a82428c4f92150 (patch)
treeae706240fdc3027bbb519b445b159f2f307098fc /gnu
parenta3e196f69ea4fd5bf9fc90dab3b6ba86e33dbb66 (diff)
downloadguix-29b0fc4cdaf8d215b83dddbb98a82428c4f92150.tar.gz
gnu: Add go-github-com-lithammer-fuzzysearch.
* gnu/packages/golang.scm (go-github-com-lithammer-fuzzysearch): New
  variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 779c0b6853..5c0b79b28c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11138,6 +11138,35 @@ terminal.")
 serialiser for Go.")
     (license license:asl2.0)))
 
+(define-public go-github-com-lithammer-fuzzysearch
+  (package
+    (name "go-github-com-lithammer-fuzzysearch")
+    (version "1.1.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lithammer/fuzzysearch")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1b036sm42cf64diwlqhx24vxy6g5afrmfbdfyqhpg8zrii3lpwns"))))
+    (build-system go-build-system)
+    (propagated-inputs (list go-golang-org-x-text))
+    (arguments
+     (list #:import-path "github.com/lithammer/fuzzysearch"
+           #:tests? #f ; Source-only package.
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; Source-only package.
+               (delete 'build))))
+    (home-page "https://github.com/lithammer/fuzzysearch")
+    (synopsis "Tiny and fast fuzzy search in Go")
+    (description
+     "A speedy fuzzy matching package for Go inspired by the JavaScript
+library bevacqua/fuzzysearch.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar