summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-27 22:46:04 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-28 00:33:48 +0100
commit29d37e999c495431eafde90027d2b97b16d0db4e (patch)
tree022a13f25e84bd32055fd38b58a5ade15641f693 /gnu
parent7349fed5918e284ae5014c3bf3a230fc62a9e13b (diff)
downloadguix-29d37e999c495431eafde90027d2b97b16d0db4e.tar.gz
gnu: make-bootstrap: Build grep without PCRE support.
Partly fixes <https://bugs.gnu.org/24841>.
Reported by Chris Marusich <cmmarusich@gmail.com>.

This fixes cross-compilation of the statically-linked grep.

* gnu/packages/make-bootstrap.scm (%static-inputs): Add 'inputs' field
for grep.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 07ac93686a..f1c4bf7bc5 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -197,6 +197,18 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
 				   (("/bin/sh") "sh")
 				   (("execv ") "execvp "))
 				 #t)))))))
+        ;; We don't want to retain a reference to /gnu/store in the bootstrap
+        ;; versions of egrep/fgrep, so we remove the custom phase added since
+        ;; grep@2.25. The effect is 'egrep' and 'fgrep' look for 'grep' in
+        ;; $PATH.
+        (grep (package
+                (inherit grep)
+                (inputs '())                   ;remove PCRE, which is optional
+                (arguments
+                 (substitute-keyword-arguments (package-arguments grep)
+                   ((#:phases phases)
+                    `(modify-phases ,phases
+                       (delete 'fix-egrep-and-fgrep)))))))
         (finalize (compose static-package
                            package-with-relocatable-glibc)))
     `(,@(map (match-lambda
@@ -209,17 +221,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                ("patch" ,patch)
                ("coreutils" ,coreutils)
                ("sed" ,sed)
-               ;; We don't want to retain a reference to /gnu/store in the
-               ;; bootstrap versions of egrep/fgrep, so we remove the custom
-               ;; phase added since grep@2.25. The effect is 'egrep' and
-               ;; 'fgrep' look for 'grep' in $PATH.
-               ("grep" ,(package
-                          (inherit grep)
-                          (arguments
-                            (substitute-keyword-arguments (package-arguments grep)
-                              ((#:phases phases)
-                               `(modify-phases ,phases
-                                  (delete 'fix-egrep-and-fgrep)))))))
+               ("grep" ,grep)
                ("gawk" ,gawk)))
       ("bash" ,static-bash))))