summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:39:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:06 +0200
commit29f1118b9650e64aa9395a62784823798d9a74d2 (patch)
treef762f041831a89e5b6cf305921bac2b65b324b9c /gnu
parent473abce6d4e5fec18bca3b4c22187e32c5b8927c (diff)
downloadguix-29f1118b9650e64aa9395a62784823798d9a74d2.tar.gz
gnu: Add texlive-soton.
* gnu/packages/tex.scm (texlive-soton): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9696a1b3c2..0137c811cf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27824,6 +27824,25 @@ bibliography entry.  The styles are adapted from standard ones or from
 @code{natbib} ones.")
     (license license:knuth)))
 
+(define-public texlive-soton
+  (package
+    (name "texlive-soton")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/soton/" "tex/latex/soton/")
+             (base32
+              "0ib4i98x14g5bl4l5bd9ciw6aay5n6fihkyzfls52l5y9vpyglix")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/soton")
+    (synopsis "University of Southampton-compliant slides")
+    (description
+     "The bundle contains two packages: @code{soton-palette} which defines
+colour-ways, and @code{soton-beamer}, which uses the colours to produce
+compliant presentations.")
+    (license license:lppl)))
+
 (define-public texlive-soup
   (package
     (name "texlive-soup")