summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:29 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:34 +0200
commit2abc77996eff8963e6decaf75cae7775b4044ed4 (patch)
treea977c53ee2433c9394f40651f322fc50c3d2360e /gnu
parentae9867f85c31663df9c9cff138748a3578a02330 (diff)
downloadguix-2abc77996eff8963e6decaf75cae7775b4044ed4.tar.gz
gnu: debug: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation.

* gnu/packages/debug.scm
(c-reduce)[inputs]: Add 'bash-minimal'.
(scanmem)[inputs]: Likewise.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I6cae82e90a994384aa3ddd737dd885444a0f5cad
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/debug.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 2cdf87e266..8cfc0359f5 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -143,6 +143,7 @@ program to exhibit a bug.")
     (native-inputs (list flex))
     (inputs
      `(("astyle"          ,astyle)
+       ("bash"            ,bash-minimal) ; for wrap-program
        ("llvm"            ,llvm-9)
        ("clang"           ,clang-9)
        ("indent"          ,indent)
@@ -692,7 +693,8 @@ input.  Zzuf's behaviour is deterministic, making it easy to reproduce bugs.")
            automake
            autoconf))
     (inputs
-     (list readline))
+     (list bash-minimal
+           readline))
     (propagated-inputs
      (list python-pygobject))
     (home-page "https://github.com/scanmem/scanmem")