summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-12-22 23:01:56 +0100
committerJulien Lepiller <julien@lepiller.eu>2022-01-09 10:34:50 +0100
commit2ac14410154f2490cfc234fe1b7ce4f20dc38b15 (patch)
treea8604b5bfadc71012f94517c968a2b7c11eef3f9 /gnu
parent92c63bc491a4f3098e94e7e58ec83b89f771c13c (diff)
downloadguix-2ac14410154f2490cfc234fe1b7ce4f20dc38b15.tar.gz
gnu: ocaml-migrate-parstree-1: Only build ocaml4.07 variant.
* gnu/packages/ocaml.scm (ocaml-migrate-parsetree-1): Rename to...
(ocaml4.07-migrate-parsetree): ...this.  Use package-with-ocaml4.07.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e7055031d7..d69cbebf81 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1810,31 +1810,32 @@ module of this library is parameterised by the type of S-expressions.")
     (propagated-inputs
      (list ocaml-ppx-derivers ocamlbuild ocaml-result))
     (properties `((upstream-name . "ocaml-migrate-parsetree")
-                  ;; OCaml 4.07 packages require version 1.*
-                  (ocaml4.07-variant . ,(delay (package-with-ocaml4.07 ocaml-migrate-parsetree-1)))))
+                  (ocaml4.07-variant . ,(delay ocaml4.07-migrate-parsetree))))
     (synopsis "OCaml parsetree converter")
     (description "This library converts between parsetrees of different OCaml
 versions.  For each version, there is a snapshot of the parsetree and conversion
 functions to the next and/or previous version.")
     (license license:lgpl2.1+)))
 
-(define-public ocaml-migrate-parsetree-1
-  (package
-    (inherit ocaml-migrate-parsetree)
-    (name "ocaml-migrate-parsetree-1")
-    (version "1.8.0")
-    (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url home-page)
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "16x8sxc4ygxrr1868qpzfqyrvjf3hfxvjzmxmf6ibgglq7ixa2nq"))))
-    (properties '((upstream-name . "ocaml-migrate-parsetree")))))
+;; OCaml 4.07 packages require version 1.*
+(define-public ocaml4.07-migrate-parsetree
+  (package-with-ocaml4.07
+    (package
+      (inherit ocaml-migrate-parsetree)
+      (name "ocaml-migrate-parsetree")
+      (version "1.8.0")
+      (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit (string-append "v" version))))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "16x8sxc4ygxrr1868qpzfqyrvjf3hfxvjzmxmf6ibgglq7ixa2nq"))))
+      (properties '((upstream-name . "ocaml-migrate-parsetree"))))))
 
 (define-public ocaml4.07-ppx-tools-versioned
   (package-with-ocaml4.07