summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-03 01:04:57 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-03 01:18:28 +0200
commit2b2fdd45bb2470765c3a9e54aac7cc56969685be (patch)
tree867a9fb98458643a77c36f74ff6dd9d96b903db0 /gnu
parent423002544d7f1b57c361445c65dfcdd905b07ac2 (diff)
downloadguix-2b2fdd45bb2470765c3a9e54aac7cc56969685be.tar.gz
gnu: qemu: Upgrade to 1.5.1.
* gnu/packages/qemu.scm (qemu-kvm): Add `--cc' configure option.
  Add PIXMAN and ALSA-LIB as inputs.
  (qemu): Upgrade to 1.5.1  Remove autotool hack for pixman.  Patch
  tests/libqtest.c.  Remove Autoconf, Automake, and Libtool from the
  inputs.  Fix `home-page'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qemu.scm30
1 files changed, 10 insertions, 20 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index b10935ce0d..1bb95840f0 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -34,6 +34,7 @@
   #:use-module (gnu packages attr)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages samba)
+  #:use-module (gnu packages xorg)
   #:use-module (gnu packages perl))
 
 (define-public qemu-kvm
@@ -62,6 +63,7 @@
                      (setenv "LDFLAGS" "-lrt")
                      (zero?
                       (system* "./configure"
+                               (string-append "--cc=" (which "gcc"))
                                (string-append "--prefix=" out)
                                (string-append "--smbd=" samba
                                               "/sbin/smbd")))))
@@ -74,11 +76,12 @@
        ("ncurses" ,ncurses)
        ("libpng" ,libpng)
        ("libjpeg" ,libjpeg-8)
+       ("pixman" ,pixman)
        ;; ("vde2" ,vde2)
        ("util-linux" ,util-linux)
        ;; ("pciutils" ,pciutils)
        ("pkg-config" ,pkg-config)
-       ;; ("alsa-lib" ,alsa-lib)
+       ("alsa-lib" ,alsa-lib)
        ;; ("SDL" ,SDL)
        ("zlib" ,zlib)
        ("attr" ,attr)
@@ -113,7 +116,7 @@ underway to get the required changes upstream.")
   ;; The real one, with a complete target list.
   (package (inherit qemu-kvm)
     (name "qemu")
-    (version "1.3.1")
+    (version "1.5.1")
     (location (source-properties->location (current-source-location)))
     (source (origin
              (method url-fetch)
@@ -121,31 +124,18 @@ underway to get the required changes upstream.")
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1bqfrb5dlsxm8gxhkksz8qzi5fhj3xqhxyfwbqcphhcv1kpyfwip"))))
+               "1s7316pgizpayr472la8p8a4vhv7ymmzd5qlbkmq6y9q5zpa25ac"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qemu-kvm)
        ((#:phases phases)
         `(alist-cons-before
           'build 'pre-build
           (lambda* (#:key inputs #:allow-other-keys)
-            (let ((libtool    (assoc-ref inputs "libtool"))
-                  (pkg-config (assoc-ref inputs "pkg-config")))
-              ;; XXX: For lack of generic search path handling.
-              (setenv "ACLOCAL_PATH"
-                      (format #f "~a/share/aclocal:~a/share/aclocal"
-                              libtool pkg-config)))
-
-            ;; For pixman's `configure' script.
-            (setenv "CONFIG_SHELL" (which "bash"))
-
-            (substitute* "pixman/configure.ac"
-              (("AM_CONFIG_HEADER") "AC_CONFIG_HEADERS")))
+            (substitute* "tests/libqtest.c"
+              (("/bin/sh") (which "sh"))))
           ,phases))))
-    (native-inputs `(("autoconf" ,autoconf-wrapper) ; for "pixman"
-                     ("automake" ,automake)
-                     ("libtool" ,libtool)
-                     ("libtool-bin" ,libtool "bin")
-                     ("perl" ,perl)))
+    (native-inputs `(("perl" ,perl)))
+    (home-page "http://www.qemu-project.org")
     (description
      "QEMU is a generic and open source machine emulator and virtualizer.