summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-12-16 13:25:20 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-12-21 22:10:19 +0100
commit2b335e87f7f25bfa5e51f3d840673a3bf8d6d014 (patch)
treef76aac277aca4f72335ebf2037a8f183179cb90b /gnu
parent14fae62df8dabffce711c4805c9fdd7a226f906a (diff)
downloadguix-2b335e87f7f25bfa5e51f3d840673a3bf8d6d014.tar.gz
gnu: Add ocaml5.0-eio-luv.
* gnu/packages/ocaml.scm (ocaml5.0-eio-luv): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 769a628acc..c78d8a2b6d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2833,6 +2833,21 @@ OCaml with fibers.")
 (define-public ocaml5.0-eio
   (package-with-ocaml5.0 ocaml-eio))
 
+(define ocaml-eio-luv
+  (package
+    (inherit ocaml-eio)
+    (name "ocaml-eio-luv")
+    (arguments `(#:package "eio_luv"
+                 #:test-target "."))
+    (propagated-inputs (list ocaml-eio ocaml-luv))
+    (native-inputs (list ocaml-mdx))
+    (synopsis "Libuv-based backend for Ocaml Eio")
+    (description "@code{Eio_luv} provides a cross-platform backend for
+@code{Ocaml Eio}'s APIs using luv (libuv)")))
+
+(define-public ocaml5.0-eio-luv
+  (package-with-ocaml5.0 ocaml-eio-luv))
+
 (define-public ocaml-lwt
   (package
     (name "ocaml-lwt")