summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-16 00:29:09 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-19 20:28:01 +0200
commit2bae85d39b5a440863e745c053ae43dfa047a3b7 (patch)
tree08c354aefda0cad2a535ca0f5c5b159302ae5f81 /gnu
parenta1acec2fe9bbf8aa95f922efc9d8bba6d7eba172 (diff)
downloadguix-2bae85d39b5a440863e745c053ae43dfa047a3b7.tar.gz
gnu: openttd-gfx: Use new package style.
* gnu/packages/games.scm (openttd-gfx)[arguments]: Convert to list of
G-Expressions.
[native-inputs]: Drop labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm45
1 files changed, 24 insertions, 21 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 42de2f78bc..2e122ad05f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4300,22 +4300,24 @@ engine.  When you start it you will be prompted to download a graphics set.")
          "0nhzlk6s73qvznm5fdwcs1b42g2plf26s5ag39fvck45zm7m48jk"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
-                          (string-append "INSTALL_DIR="
-                                         (assoc-ref %outputs "out")
-                                         "/share/games/openttd/baseset/opengfx"))
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda _
-             ;; Make sure HOME is writable for GIMP.
-             (setenv "HOME" (getcwd))
+     (list
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target))
+              (string-append "INSTALL_DIR="
+                             #$output
+                             "/share/games/openttd/baseset/opengfx"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'configure
+            (lambda _
+              ;; Make sure HOME is writable for GIMP.
+              (setenv "HOME" (getcwd))
 
-             ;; Redirect stdout, not stderr, to /dev/null. This prevents
-             ;; dos2unix from receiving its version information as a flag.
-             (substitute* "Makefile"
-               (("\\$\\(UNIX2DOS\\) -q --version 2>/dev/null")
-                "$(UNIX2DOS) -q --version 1>/dev/null")))))
+              ;; Redirect stdout, not stderr, to /dev/null. This prevents
+              ;; dos2unix from receiving its version information as a flag.
+              (substitute* "Makefile"
+                (("\\$\\(UNIX2DOS\\) -q --version 2>/dev/null")
+                 "$(UNIX2DOS) -q --version 1>/dev/null")))))
        ;; The check phase for this package only checks the md5sums of the built
        ;; GRF files against the md5sums of the release versions. Because we use
        ;; different software versions than upstream does, some of the md5sums
@@ -4323,12 +4325,13 @@ engine.  When you start it you will be prompted to download a graphics set.")
        ;; to disable this test.
        #:tests? #f
        #:parallel-build? #f))
-    (native-inputs `(("dos2unix" ,dos2unix)
-                     ("gimp" ,gimp)
-                     ("grfcodec" ,grfcodec)
-                     ("nml" ,nml)
-                     ("which" ,which)
-                     ("python" ,python)))
+    (native-inputs
+     (list dos2unix
+           gimp
+           grfcodec
+           nml
+           which
+           python))
     (home-page "http://dev.openttdcoop.org/projects/opengfx")
     (synopsis "Base graphics set for OpenTTD")
     (description