summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-02-01 10:36:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-05 06:56:43 +0100
commit2c3d1cdfccf60685877f2848eeb00a395f710dfd (patch)
tree452be9e1ca076e053cebba1cb750e62ce31a3c33 /gnu
parentc3e61c8c1f5ce867408ba7a113882a4b0ad5b2cb (diff)
downloadguix-2c3d1cdfccf60685877f2848eeb00a395f710dfd.tar.gz
gnu: Rename 'samba/fixed' to 'samba/pinned'.
* gnu/packages/samba.scm: Rename variable 'samba/fixed' to 'samba/pinned' and
'samba/fixed-patched' to 'samba/fixed'.
* gnu/packages/gnome.scm (libsoup-minimal)[inputs]: Replace 'samba/fixed' with
'samba/pinned'.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/samba.scm10
2 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6a4d3182b2..19a96ef9f4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5199,7 +5199,7 @@ as OpenStreetMap, OpenCycleMap, OpenAerialMap and Maps.")
            sqlite
            zlib))
     (inputs
-     (list mit-krb5 samba/fixed))     ; For ntlm_auth support
+     (list mit-krb5 samba/pinned))     ; For ntlm_auth support
     (home-page "https://wiki.gnome.org/Projects/libsoup")
     (synopsis "GLib-based HTTP Library")
     (description
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 00442d9645..da103ed839 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -275,14 +275,14 @@ Samba is an important component to seamlessly integrate Linux/Unix Servers and
 Desktops into Active Directory environments using the winbind daemon.")
     (license license:gpl3+)))
 
-;;; FIXME: Invert inheritance relationship; the "fixed" package shouldn't be
+;;; FIXME: Invert inheritance relationship; the "pinned" package shouldn't be
 ;;; susceptible to changes in the free one.
-(define-public samba/fixed
+(define-public samba/pinned
   ;; Version that rarely changes, depended on by libsoup.
   (hidden-package
    (package
      (inherit samba)
-     (replacement samba/fixed-patched)
+     (replacement samba/fixed)
      (version "4.15.3")
      (source
       (origin
@@ -306,9 +306,9 @@ Desktops into Active Directory environments using the winbind daemon.")
             libxslt
             libxml2)))))
 
-(define-public samba/fixed-patched
+(define-public samba/fixed
   (package
-    (inherit samba/fixed)
+    (inherit samba/pinned)
     ;; This is 4.15.13, but we need to trim the store file name to have
     ;; the same length as the one we are grafting above.
     (version "4.15.A")