summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:03:51 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:13 +0300
commit2c63f724862984883825bd7be13dff02b25f6e48 (patch)
treee0860c6cfcc9bef6b844d306a9acb2f011d6b721 /gnu
parentc1b9d72ca1e0922eb67f943c2f3521cde3251482 (diff)
downloadguix-2c63f724862984883825bd7be13dff02b25f6e48.tar.gz
gnu: Add emacs-discover-my-major.
* gnu/packages/emacs.scm (emacs-discover-my-major): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3a3bbb4ff7..ca10da740e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9097,3 +9097,26 @@ CSS, JavaScript, JSON.")
       (description "This package provides an Emacs Helm interface to search
 throw a shell history.")
       (license license:gpl3+))))
+
+(define-public emacs-discover-my-major
+  (package
+    (name "emacs-discover-my-major")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://github.com/steckerhalter/discover-my-major"
+                       "/archive/" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0nah41f92rrl2l405kpqr6iaks11jyclgl4z7ilfymbr4ifmsiyl"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-makey" ,emacs-makey)))
+    (home-page "https://github.com/steckerhalter/discover-my-major")
+    (synopsis "Discover key bindings for the current Emacs major mode")
+    (description "This package provides allows to discover key bindings and
+their meaning for the current Emacs major-mode.")
+    (license license:gpl3+)))