summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-03-16 15:57:34 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-03-16 16:48:11 +0100
commit2da3c84ab7e5b40244e23a78d3b0994dcf6d97de (patch)
tree1e0394654571d9253bb85ca4cb04ae0b5f109443 /gnu
parent797e308047a81d63f2e55b8748ce743d6421cb8f (diff)
downloadguix-2da3c84ab7e5b40244e23a78d3b0994dcf6d97de.tar.gz
gnu: opencpn: Update to 5.6.0.
* gnu/packages/geo.scm (opencpn): Update to 5.6.0.
  [inputs]: Add alsa-utils, eudev, jasper, libjpeg-turbo and libusb.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/geo.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 6b3448a261..538db2dde4 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -88,6 +88,8 @@
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages java)
   #:use-module (gnu packages kde)
+  #:use-module (gnu packages libusb)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages multiprecision)
@@ -2012,30 +2014,35 @@ exchanged form one Spatial DBMS and the other.")
 (define-public opencpn
   (package
     (name "opencpn")
-    (version "5.2.4")
+    (version "5.6.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/OpenCPN/OpenCPN")
-             (commit (string-append "v" version))))
+             (commit (string-append "Release_" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0ffx0lmz1mp5433zqyxigy4qqav32xprpagd66krvihkyvqp2y6y"))))
+        (base32 "0g5x45wv3djfjmigk6kgs0i63yp8rs1fbmm4pb15wb3z6dml624y"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)))
     (inputs
-     (list bzip2
+     (list alsa-utils
+           bzip2
            cairo
            curl
+           eudev
            glu
            gtk+
+           jasper
            libarchive
            libelf
            libexif
+           libjpeg-turbo
            libsndfile
+           libusb
            lz4
            mesa
            pango