summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-25 21:12:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-26 09:54:34 +0300
commit2de39dc723545e2e3dee9e8ef6a5f55db335c958 (patch)
treea7401ec4636b9ff4d8aec447529633f0e8d92f5b /gnu
parentcbc139a791eb8a664c28c2d28033daa0baa102e3 (diff)
downloadguix-2de39dc723545e2e3dee9e8ef6a5f55db335c958.tar.gz
gnu: go-github-com-mitchellh-go-homedir: Update version string.
The commit was actually at the 1.0.0 tag.

* gnu/packages/golang.scm (go-github-com-mitchellh-go-homedir)[version]:
Update to proper version.
[source]: Update commit for git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm46
1 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ce21412536..cd6054de8c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2341,29 +2341,27 @@ statistics for wrapped connections.")
       (license license:expat))))
 
 (define-public go-github-com-mitchellh-go-homedir
-  (let ((commit "ae18d6b8b3205b561c79e8e5f69bff09736185f4")
-        (revision "0"))
-    (package
-      (name "go-github-com-mitchellh-go-homedir")
-      (version (git-version "1.0.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/mitchellh/go-homedir.git")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0f0z0aa4wivk4z1y503dmnw0k0g0g403dly8i4q263gfshs82sbq"))))
-      (build-system go-build-system)
-      (arguments
-       (quote (#:import-path "github.com/mitchellh/go-homedir"
-               ;; TODO: Tests fail because it tries to access home.
-               #:tests? #f)))
-      (home-page "https://github.com/mitchellh/go-homedir")
-      (synopsis "Go library for detecting and expanding the user's home directory without cgo")
-      (description "This is a Go library for detecting the user's home
+  (package
+    (name "go-github-com-mitchellh-go-homedir")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mitchellh/go-homedir.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0f0z0aa4wivk4z1y503dmnw0k0g0g403dly8i4q263gfshs82sbq"))))
+    (build-system go-build-system)
+    (arguments
+     (quote (#:import-path "github.com/mitchellh/go-homedir"
+             ;; TODO: Tests fail because it tries to access home.
+             #:tests? #f)))
+    (home-page "https://github.com/mitchellh/go-homedir")
+    (synopsis "Go library for detecting and expanding the user's home directory without cgo")
+    (description "This is a Go library for detecting the user's home
 directory without the use of @command{cgo}, so the library can be used in
 cross-compilation environments.
 
@@ -2377,7 +2375,7 @@ package cannot cross compile.  But 99% of the time the use for
 @command{os/user} is just to retrieve the home directory, which we can do for
 the current user without cgo.  This library does that, enabling
 cross-compilation.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public go-github-com-multiformats-go-multiaddr
   (let ((commit "fe1c46f8be5af4aff4db286e08839295bd922efb")