summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-06 18:49:08 -0700
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2019-09-22 08:47:52 +0200
commit2ea8b51a713716f38b99c727a6020aa471718e96 (patch)
tree852b6138efd953a00dd4c84b87196f3bd350eb18 /gnu
parentf1c4dbfa552fd543ec89a58ab9fee680272d1663 (diff)
downloadguix-2ea8b51a713716f38b99c727a6020aa471718e96.tar.gz
gnu: Add python-pyside-2-tools.
* gnu/packages/qt.scm (python-pyside-2-tools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 138ca2becb..3ee3a2c044 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2425,3 +2425,35 @@ generate Python bindings for your C or C++ code.")
                 ;; Thus, it is currently v2 or v3, but no "+".
                 license:gpl3
                 license:gpl2)))))
+
+(define-public python-pyside-2-tools
+  (let ((revision "1")
+        ;; Pinned to branches with support for qt 5.11.3
+        (commit "f1b775537e7fbd718516749583b2abf1cb6adbce"))
+    (package
+      (name "python-pyside-2-tools")
+      (version (git-version "v5.11.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://code.qt.io/pyside/pyside-tools")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1w2g5afvww9r89wmdm9jx8sz67x4bzy9difkh72n4c73ya1n91ry"))))
+      (build-system cmake-build-system)
+      (inputs
+       `(("python-pyside-2" ,python-pyside-2)
+         ("python-shiboken-2" ,python-shiboken-2)
+         ("qtbase" ,qtbase)))
+      (arguments
+       `(#:tests? #f
+         #:configure-flags '("-DBUILD_TESTS=off")))
+      (home-page "https://wiki.qt.io/Qt_for_Python")
+      (synopsis
+       "Contains command line tools for PySide2")
+      (description
+       "Contains lupdate, rcc and uic tools for PySide2")
+      (license license:gpl2))))