summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-27 21:42:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-01 12:05:13 +0100
commit2eb750ab1f1175cb20483175afa8d5143b3158cd (patch)
tree6c671428cc5ad52c1a7ee8e941111f27f34f391c /gnu
parentef7df2ca7bb212455f1d6bbef5bbf7b1ac5a189d (diff)
downloadguix-2eb750ab1f1175cb20483175afa8d5143b3158cd.tar.gz
gnu: Add r-simplermarkdown.
* gnu/packages/cran.scm (r-simplermarkdown): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index abe89201b0..abf2868122 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9652,6 +9652,33 @@ filtering functions, resampling routines, and visualization of filter models.
 It also includes interpolation functions.")
     (license license:gpl2)))
 
+(define-public r-simplermarkdown
+  (package
+    (name "r-simplermarkdown")
+    (version "0.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "simplermarkdown" version))
+       (sha256
+        (base32 "069pgx5m22rdqa21lyn5zqm9ym3g7w6z1d2wjwms8b1f2cp6266g"))))
+    (properties `((upstream-name . "simplermarkdown")))
+    (build-system r-build-system)
+    (propagated-inputs
+     ;; We cannot patch references to pandoc because the patched files are
+     ;; compiled to an opaque rdb/rdx pair.  "guix gc" would not be able to
+     ;; find the patched references in those files.
+     (list pandoc
+           r-rjson))
+    (home-page "https://github.com/djvanderlaan/simplermarkdown")
+    (synopsis "Simple engine for generating reports using R")
+    (description
+     "This package runs R-code present in a pandoc markdown file and includes
+the resulting output in the resulting markdown file.  This file can then be
+converted into any of the output formats supported by pandoc.  The package can
+also be used as an engine for writing package vignettes.")
+    (license license:gpl3+)))
+
 (define-public r-sitar
   (package
     (name "r-sitar")