summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-01-05 12:39:46 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-01-10 18:39:13 +0100
commit2ec29a8c11f4c59eb80d7dcbf476d901ee44f857 (patch)
tree38d9ce20db379d823184e98f7f4c0a83bbf9d77c /gnu
parent6688e9f4bde65ebcf5cb6e530e63e0503e075540 (diff)
downloadguix-2ec29a8c11f4c59eb80d7dcbf476d901ee44f857.tar.gz
gnu: Add r-escape.
* gnu/packages/bioconductor.scm (r-escape): New variable.

Change-Id: Ia308f9c90fa81c3304f97daa4f56ae4cd722d5cc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a7af5c42ce..8ad4a197d6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1127,6 +1127,46 @@ Ensembl.")
 Ensembl.")
     (license license:artistic2.0)))
 
+(define-public r-escape
+  (package
+    (name "r-escape")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "escape" version))
+       (sha256
+        (base32 "0bmin69ax7l5x3a0k9mv183277a0hl4znx02y79v2ilkgqkdm7fn"))))
+    (properties `((upstream-name . "escape")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biocparallel
+                             r-broom
+                             r-data-table
+                             r-dplyr
+                             r-ggplot2
+                             r-ggridges
+                             r-gseabase
+                             r-gsva
+                             r-matrix
+                             r-matrixgenerics
+                             r-msigdbr
+                             r-patchwork
+                             r-reshape2
+                             r-rlang
+                             r-singlecellexperiment
+                             r-stringr
+                             r-summarizedexperiment
+                             r-ucell))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/escape")
+    (synopsis "Single cell analysis platform for enrichment")
+    (description
+     "R-escape streamlines gene set enrichment analysis for single-cell RNA
+sequencing.  Using raw count information, Seurat objects, or
+@code{SingleCellExperiment} format, users can perform and visualize GSEA
+across individual cells.")
+    (license license:gpl2)))
+
 (define-public r-snplocs-hsapiens-dbsnp144-grch37
   (package
     (name "r-snplocs-hsapiens-dbsnp144-grch37")