summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-03-20 18:59:48 +0100
committerAndreas Enge <andreas@enge.fr>2023-03-20 19:00:02 +0100
commit30f4b3a7e87f6d89d36dad63d8c5a8d065050563 (patch)
treefa90a8e61be1e7968b403b5caab245466fa36902 /gnu
parent2336d5f57a4422d9c97db85e1c9a47763f23ad3c (diff)
downloadguix-30f4b3a7e87f6d89d36dad63d8c5a8d065050563.tar.gz
gnu: openjdk10: Apply patch again.
This partially reverts commit 7636c49b45adb9870cf416c64bde032ec858a820
where the patch was dropped.

* gnu/packages/java.scm (openjdk10)[source]: Apply patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 7cf4a4fb4b..de3a0003e5 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1045,7 +1045,9 @@ new Date();"))
                                     (find-files "." ".*.(bin|exe|jar)$"))))
               (sha256
                (base32
-                "0i47ar8lxzjrkkiwbzybfxs473390h4jq9ahm3xqdvy5zpchxy3y"))))
+                "0i47ar8lxzjrkkiwbzybfxs473390h4jq9ahm3xqdvy5zpchxy3y"))
+              (patches (search-patches
+                        "openjdk-10-idlj-reproducibility.patch"))))
     (arguments
      (substitute-keyword-arguments (package-arguments openjdk9)
        ((#:phases phases)