summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 12:40:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 13:17:51 +0100
commit30f53ec86d536e96ba5d61c526004d9dd1d7b370 (patch)
treec838d4324669704a273e46787ec2ff4b7e199a0f /gnu
parentc27927dbf5f55c088a017df6fb3976e4b4419e0e (diff)
downloadguix-30f53ec86d536e96ba5d61c526004d9dd1d7b370.tar.gz
gnu: Add r-ggextra.
* gnu/packages/cran.scm (r-ggextra): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c44749f252..79753eb8d3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11259,6 +11259,35 @@ plots.  A more generic color picker RStudio Addin is also provided to let you
 select colors to use in your R code.")
     (license license:expat)))
 
+(define-public r-ggextra
+  (package
+    (name "r-ggextra")
+    (version "0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggExtra" version))
+       (sha256
+        (base32
+         "1m5zpn3l3p1y3d2692gyz50m63d58m2a3b7zb595kvcffdx2qr5b"))))
+    (properties `((upstream-name . "ggExtra")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-colourpicker" ,r-colourpicker)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-gtable" ,r-gtable)
+       ("r-miniui" ,r-miniui)
+       ("r-scales" ,r-scales)
+       ("r-shiny" ,r-shiny)
+       ("r-shinyjs" ,r-shinyjs)))
+    (home-page "https://github.com/daattali/ggExtra")
+    (synopsis "Marginal histograms for ggplot2 and other enhancements")
+    (description
+     "This package is a collection of functions and layers to enhance ggplot2.
+The flagship function is @code{ggMarginal()}, which can be used to add
+marginal histograms/boxplots/density plots to ggplot2 scatterplots.")
+    (license license:expat)))
+
 (define-public r-minpack-lm
   (package
     (name "r-minpack-lm")