summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 12:38:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:49 +0200
commit3121f754c415491dbae129b986a94b2c181a7cfd (patch)
tree13c603a615fa07b7de02053153c1d39791a06e19 /gnu
parent9e981db3085ba09b45a1a715f0bc554ac9847d80 (diff)
downloadguix-3121f754c415491dbae129b986a94b2c181a7cfd.tar.gz
gnu: Add texlive-scheme-context.
* gnu/packages/tex.scm (texlive-scheme-context): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm68
1 files changed, 51 insertions, 17 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 20dd7e7bec..30ce70619b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15458,23 +15458,6 @@ break statement, except that the loop does not terminate until the end of the
 current iteration.")
     (license license:lppl)))
 
-(define-public texlive-scheme-minimal
-  (package
-    (name "texlive-scheme-minimal")
-    (version (number->string %texlive-revision))
-    (source #f)
-    (build-system trivial-build-system)
-    (arguments (list #:builder #~(mkdir #$output)))
-    (propagated-inputs (list texlive-collection-basic))
-    (home-page "https://www.tug.org/texlive/")
-    (synopsis "Minimal scheme (plain only)")
-    (description
-     "This is the minimal TeX Live scheme, with support for only plain
-TeX. (No LaTeX macros.) LuaTeX is included because Lua scripts are used in TeX
-Live infrastructure.  This scheme corresponds exactly to
-@code{collection-basic}.")
-    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
-
 (define-public texlive-scheme-basic
   (package
     (name "texlive-scheme-basic")
@@ -15494,6 +15477,57 @@ Computer Modern fonts.  This scheme corresponds to @code{collection-basic} and
 
 (define-deprecated-package texlive-base texlive-scheme-basic)
 
+(define-public texlive-scheme-context
+  (package
+    (name "texlive-scheme-context")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-antt
+           texlive-asana-math
+           texlive-ccicons
+           texlive-collection-context
+           texlive-collection-metapost
+           texlive-dejavu
+           texlive-eulervm
+           texlive-gentium-tug
+           texlive-iwona
+           texlive-kurier
+           texlive-ly1
+           texlive-manfnt-font
+           texlive-marvosym
+           texlive-mflogo-font
+           texlive-poltawski
+           texlive-pxfonts
+           texlive-tex-gyre
+           texlive-tex-gyre-math
+           texlive-txfonts
+           texlive-wasy
+           texlive-xits))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "ConTeXt scheme")
+    (description "This is the TeX Live scheme for installing ConTeXt.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
+(define-public texlive-scheme-minimal
+  (package
+    (name "texlive-scheme-minimal")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs (list texlive-collection-basic))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Minimal scheme (plain only)")
+    (description
+     "This is the minimal TeX Live scheme, with support for only plain
+TeX. (No LaTeX macros.) LuaTeX is included because Lua scripts are used in TeX
+Live infrastructure.  This scheme corresponds exactly to
+@code{collection-basic}.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar