summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:23:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:23:11 +0200
commit321c73c3873eb14c5efa5f88694685031089c46d (patch)
treed1d58912ffc3fdaabca77dee633c719d83c6c45c /gnu
parent844cc1929f5a7f53032c3db296cda5067f210a19 (diff)
downloadguix-321c73c3873eb14c5efa5f88694685031089c46d.tar.gz
gnu: gnome-disk-utility: Don't create icon cache.
* gnu/packages/gnome.scm (gnome-disk-utility)[arguments]: Add phase to
skip creating the gtk icon cache.
[native-inputs]: Remove gtk+:bin.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cd881b5b87..21aad2328a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -569,9 +569,17 @@ and keep up to date translations of documentation.")
                (base32
                 "1365fabz3q7n3bl775z82m1nzg18birxxyd7l2ssbbkqrx3h7wgi"))))
     (build-system meson-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t)))))
     (native-inputs
      `(("glib:bin" ,glib "bin")
-       ("gtk+" ,gtk+ "bin")             ; gtk-update-icon-cache
        ("intltool" ,intltool)
        ("pkg-config" ,pkg-config)
        ("docbook-xml" ,docbook-xml)