summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:26:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:38 +0100
commit322e8d85798f32bc0a4f5bf30d4896931046780d (patch)
treed0d6b417186186a9e4c3c0d16563dff8b6a0a7b3 /gnu
parent8990fc1584ce2270063774e098ebf2ac8090c32d (diff)
downloadguix-322e8d85798f32bc0a4f5bf30d4896931046780d.tar.gz
gnu: Add r-sysfonts.
* gnu/packages/cran.scm (r-sysfonts): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d4bfcfaaa0..2838dcb37a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16437,3 +16437,29 @@ introductions, and clickable hints in a Shiny application.  It supports both
 static introductions in the UI, and programmatic introductions from the
 server-side.")
     (license license:agpl3+)))
+
+(define-public r-sysfonts
+  (package
+    (name "r-sysfonts")
+    (version "0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "sysfonts" version))
+       (sha256
+        (base32
+         "0wng902plryf2d8fc7k7m3jx11acz51kb2d91cqbyhq7xpk06z43"))))
+    (properties `((upstream-name . "sysfonts")))
+    (build-system r-build-system)
+    (inputs
+     `(("freetype" ,freetype)
+       ("libpng" ,libpng)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/yixuan/sysfonts")
+    (synopsis "Loading fonts into R")
+    (description
+     "This is a package to simplify loading of system fonts and Google Fonts
+into R, in order to support other packages.")
+    (license license:gpl2)))