summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-22 23:45:44 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-22 23:45:44 +0100
commit32795fcffbf4078de2aec97f4dd2dcb9bcc55c8f (patch)
tree654e4a50da8d513e178390d6eb138a73842732d6 /gnu
parentad7583f6f55486636dbadd716e493ddadac255d2 (diff)
downloadguix-32795fcffbf4078de2aec97f4dd2dcb9bcc55c8f.tar.gz
gnu: guile-2.0: Switch to libgc 7.4.0.
* gnu/packages/guile.scm (guile-2.0): Use LIBGC-7.4.
  (guile-2.0/fixed): Keep using LIBGC.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 40d9ae7df8..1f423256f2 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,7 +35,9 @@
   #:use-module (gnu packages which)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix utils)
+  #:use-module (ice-9 match))
 
 ;;; Commentary:
 ;;;
@@ -134,7 +136,7 @@ without requiring the source code to be rewritten.")
 
       ;; The headers and/or `guile-2.0.pc' refer to these packages, so they
       ;; must be propagated.
-      ("bdw-gc" ,libgc)
+      ("bdw-gc" ,libgc-7.4)
       ("gmp" ,gmp)))
 
    (self-native-input? #t)
@@ -177,7 +179,15 @@ without requiring the source code to be rewritten.")
 (define-public guile-2.0/fixed
   ;; A package of Guile 2.0 that's rarely changed.  It is the one used
   ;; in the `base' module, and thus changing it entails a full rebuild.
-  guile-2.0)
+  (package (inherit guile-2.0)
+    (location (source-properties->location (current-source-location)))
+
+    ;; Keep using the stable libgc.
+    (propagated-inputs (map (match-lambda
+                             (("bdw-gc" _)
+                              `("bdw-gc" ,libgc))
+                             (x x))
+                            (package-propagated-inputs guile-2.0)))))
 
 
 ;;;