summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-12-12 14:18:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-12-12 22:08:45 +0100
commit32fd2600766d06724c6a7f6fb9b3d9029fbff911 (patch)
tree34c6f63509f539b42d3ef6e49e3b58cdc87f0e34 /gnu
parentbea3cf4b90a6ac7bbf651d1b553ff044a8a8ba77 (diff)
downloadguix-32fd2600766d06724c6a7f6fb9b3d9029fbff911.tar.gz
gnu: cssc: Update to 1.4.0.
* gnu/packages/version-control.scm (cssc): Update to 1.4.0.
[source]: Remove unneeded patches (i.e. all of them).
* gnu/packages/patches/cssc-gets-undeclared.patch: Delete file.
* gnu/packages/patches/cssc-missing-include.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): Remove deleted patches.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/patches/cssc-gets-undeclared.patch17
-rw-r--r--gnu/packages/patches/cssc-missing-include.patch12
-rw-r--r--gnu/packages/version-control.scm6
4 files changed, 2 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c6cb55b06f..fae868bfdb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -508,8 +508,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/crda-optional-gcrypt.patch		\
   %D%/packages/patches/crossmap-allow-system-pysam.patch	\
   %D%/packages/patches/csound-header-ordering.patch		\
-  %D%/packages/patches/cssc-gets-undeclared.patch               \
-  %D%/packages/patches/cssc-missing-include.patch               \
   %D%/packages/patches/clucene-contribs-lib.patch               \
   %D%/packages/patches/cursynth-wave-rand.patch			\
   %D%/packages/patches/cyrus-sasl-CVE-2013-4122.patch		\
diff --git a/gnu/packages/patches/cssc-gets-undeclared.patch b/gnu/packages/patches/cssc-gets-undeclared.patch
deleted file mode 100644
index 68c607cf58..0000000000
--- a/gnu/packages/patches/cssc-gets-undeclared.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-CSSC uses a gets in a couple of places.  For security reasons, modern gnulib
-does not allow this.  This patch allows it again.
---- CSSC-1.3.0/gl/lib/stdio.in.h	2010-05-15 00:15:35.000000000 +0200
-+++ CSSC-1.3.0/gl/lib/stdio.in.h	2014-02-03 21:27:10.000000000 +0100
-@@ -135,12 +135,6 @@
-                  "use gnulib module fflush for portable POSIX compliance");
- #endif
- 
--/* It is very rare that the developer ever has full control of stdin,
--   so any use of gets warrants an unconditional warning.  Assume it is
--   always declared, since it is required by C89.  */
--#undef gets
--_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
--
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@
- #  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
diff --git a/gnu/packages/patches/cssc-missing-include.patch b/gnu/packages/patches/cssc-missing-include.patch
deleted file mode 100644
index 3cef9c15f1..0000000000
--- a/gnu/packages/patches/cssc-missing-include.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Added a missing include file (necessary for gid_t and others).
-So far as I am aware, this has not been added upstream yet.
---- CSSC-1.3.0/src/file.h	2010-05-16 19:31:33.000000000 +0200
-+++ CSSC-1.3.0/src/file.h	2014-02-03 21:48:30.000000000 +0100
-@@ -30,6 +30,7 @@
- #ifndef CSSC__FILE_H__
- #define CSSC__FILE_H__
- 
-+#include <sys/types.h>
- #include "filelock.h"
- 
- enum create_mode {
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index f6845fab04..7918b90ca6 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -889,16 +889,14 @@ large, complex patch files.")
 (define-public cssc
   (package
     (name "cssc")
-    (version "1.3.0")
+    (version "1.4.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/" name "/CSSC-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0bkw6fjh20ppvn54smv05461lm1vcwvn02avx941c4acafmkl1cm"))
-              (patches (search-patches "cssc-gets-undeclared.patch"
-                                       "cssc-missing-include.patch"))))
+                "15191dh8hr46cvssmv4v52gymiiyk6ca9j1bfimlqakcqab6y51h"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases