summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-31 11:18:32 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-20 10:11:32 +0200
commit360c8873ff693297a6a30c8142ec5698e05edf99 (patch)
tree5cf1d7bdee7bbc2c14e97334af3affac1bc2dc82 /gnu
parentd4306847bf8736bf60a2ff435fd2d8ef763f769c (diff)
downloadguix-360c8873ff693297a6a30c8142ec5698e05edf99.tar.gz
gnu: guile: Skip hanging and failing pipe tests on the Hurd.
* gnu/packages/guile.scm (guile-3.0)[arguments]: When building on the Hurd,
add stage 'disable-popen.test-open-pipe' to avoid running the
open-input-pipe test (hangs) and open-output-pipe test (fails.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 48bee600a9..06ffc39f1d 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -378,6 +378,19 @@ without requiring the source code to be rewritten.")
                                (search-patch "guile-hurd-posix-spawn.patch")))
                           (invoke "patch" "--force" "-p1" "-i" patch))))
                    #~())
+            #$@(if (system-hurd?)
+                   #~((add-after 'unpack 'disable-popen.test-no-duplicate
+                        ;; This test hangs on the Hurd.
+                        (lambda _
+                          (substitute* "test-suite/tests/popen.test"
+                            (("\\(pass-if \"no duplicate\".*" all)
+                             (string-append
+                              all
+                              (object->string
+                               '(when (string-ci= "GNU"
+                                                  (vector-ref (uname) 0))
+                                  (throw 'unresolved)))))))))
+                   #~())
             #$@(if (target-ppc32?)
                    #~((add-after 'unpack 'adjust-bootstrap-flags
                         (lambda _