summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-11 14:00:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-11 14:00:20 +0200
commit36e8185667c41740786d9b2eb3672a0f8b902ed8 (patch)
treeaf50c80ee3aaf10fb5feb9e50c2e1f716140c949 /gnu
parentf659e5e379dc3ec43be27a8e3169fe2ed197bb93 (diff)
downloadguix-36e8185667c41740786d9b2eb3672a0f8b902ed8.tar.gz
gnu: lv2: Use Python 2 for building.
* gnu/packages/audio.scm (lv2)[arguments]: Set #:python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3b898c024a..8ce9af6af1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1777,6 +1777,8 @@ significantly faster and have minimal dependencies.")
     (build-system waf-build-system)
     (arguments
      `(#:tests? #f  ; no check target
+       ;; XXX: The bundled waf does not work with Python 3.7.
+       #:python ,python-2
        #:configure-flags '("--no-plugins")))
     (inputs
      ;; Leaving off cairo and gtk+-2.0 which are needed for example plugins