summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2022-06-16 18:37:16 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-06 19:40:17 +0000
commit36f5db706c22d7d643154fc841d0a4018195189b (patch)
tree3eb2fe3779d16d97263b338a0f81e6d82c0e37ea /gnu
parent7d3aa578ef0b7fcfcddf0623f806ec625aab6ccd (diff)
downloadguix-36f5db706c22d7d643154fc841d0a4018195189b.tar.gz
gnu: Add python-pynrrd.
* gnu/packages/python-science.scm (python-pynrrd): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 2b4e74f9be..d2404529bc 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2600,6 +2600,32 @@ networking protocol.  It allows the easy creation of DICOM
 Providers}.")
     (license license:expat)))
 
+(define-public python-pynrrd
+  (package
+    (name "python-pynrrd")
+    (version "0.4.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mhe/pynrrd")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12vlgx2k7jxbq9r9maiix4dbk8alixa0il420bqwhzln08s3chz1"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (delete 'ensure-no-mtimes-pre-1980))))
+    (propagated-inputs (list python-numpy))
+    (home-page "https://github.com/mhe/pynrrd")
+    (synopsis "Python module for reading and writing NRRD files")
+    (description
+     "@code{pynrrd} is a Python module for reading and writing NRRD
+files into and from numpy arrays.")
+    (license license:expat)))
+
 (define-public python-libneuroml
   (package
     (name "python-libneuroml")