summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-29 13:16:11 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:14 -0500
commit3748992a9e50bfa4e4d90f147302c3d4cb3c3990 (patch)
tree380b7870a92d3ab82722a9d450a6f1d63d516e58 /gnu
parent21ed1154c844cff70df603c1c05a4a1cfe7e707f (diff)
downloadguix-3748992a9e50bfa4e4d90f147302c3d4cb3c3990.tar.gz
gnu: ghex: Update to 3.18.4.
* gnu/packages/gnome.scm (ghex): Update to 3.18.4.
[build-system]: Use meson-build-system.
[arguments]: Set glib-or-gtk? flag and add 'skip-gtk-update-icon-cache' phase.
[native-inputs]: Add glib:bin.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 48d4bf74af..3f9085ce0d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8448,7 +8448,7 @@ micro-pauses and rest breaks, and restricts you to your daily limit.")
 (define-public ghex
   (package
     (name "ghex")
-    (version "3.18.3")
+    (version "3.18.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/ghex/"
@@ -8456,10 +8456,21 @@ micro-pauses and rest breaks, and restricts you to your daily limit.")
                                   "ghex-" version ".tar.xz"))
               (sha256
                (base32
-                "1lq8920ad2chi9ibmyq0x9hg9yk63b0kdbzid03w42cwdzw50x66"))))
-    (build-system glib-or-gtk-build-system)
+                "1h1pjrr9wynclfykizqd78dbi785wjz6b63p31k87kjvzy8w3nf2"))))
+    (build-system meson-build-system)
+    (arguments
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") (which "true")))
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("glib:bin" ,glib "bin") ; for glib-compile-schemas
        ("gnome-common" ,gnome-common)
        ("which" ,which)
        ("intltool" ,intltool)