summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:50 +0200
commit375bb1bcde21e63a367e990dc1317b851a973edd (patch)
treea975f88ff07e09b0b0a1e3938922c7f85faf0aba /gnu
parent97238158f5c97a9a349afc56906a328941b4551f (diff)
downloadguix-375bb1bcde21e63a367e990dc1317b851a973edd.tar.gz
gnu: Add texlive-texments.
* gnu/packages/tex.scm (texlive-texments): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e15eeacdf9..a7552f665d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97779,6 +97779,27 @@ current position automatically.  For chess fonts, the package uses the
 @code{chessfss} system.")
     (license license:lppl)))
 
+(define-public texlive-texments
+  (package
+    (name "texlive-texments")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/texments/"
+                   "source/latex/texments/"
+                   "tex/latex/texments/")
+             (base32
+              "06k1nfxdnl811sw4n9blp863a903ryh7b4m79rjj367kzs2zkbca")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/texments")
+    (synopsis "Using the Pygments highlighter in LaTeX")
+    (description
+     "This package provides a package which allows to use the Pygments highlighter
+inside LaTeX documents.  Pygments supports syntax colouring of over 50 types
+of files, and ships with multiple colour schemes.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar