summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authordan <i@dan.games>2022-12-13 07:59:11 +0800
committerLudovic Courtès <ludo@gnu.org>2023-01-17 16:05:21 +0100
commit37916ba175acbdc859c4aa47a4b49d9e7988ba6f (patch)
treeaa7b2819b19725d58a98133fe07017ef1b572c7c /gnu
parent1df9ec6febfff524d0dded12fb6ea7c945f30501 (diff)
downloadguix-37916ba175acbdc859c4aa47a4b49d9e7988ba6f.tar.gz
gnu: Add raylib.
* gnu/packages/game-development.scm (raylib): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a06e0f9fbf..e72b7cea7f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -27,6 +27,7 @@
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2835,3 +2836,35 @@ systems where you stream new navigation data in and out as the player
 progresses the level, or you may regenerate tiles as the world changes.")
       (home-page "https://github.com/recastnavigation/recastnavigation")
       (license license:zlib))))
+
+(define-public raylib
+  (package
+    (name "raylib")
+    (version "4.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/raysan5/raylib/")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "14v5iwxh8grywiyw9agpd2sfpyriq1rwwkd9f2s4iihh0z5j7hk8"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ;no test
+    (inputs (list alsa-lib
+                  libx11
+                  libxrandr
+                  libxi
+                  libxinerama
+                  libxcursor
+                  mesa))
+    (native-inputs (list pkg-config))
+    (synopsis "C library for videogame programming")
+    (description
+     "raylib is a high-level library for video game programming.  It aims to
+  abstract away platform and graphics details, allowing you to focus on
+  writing your game.")
+    (home-page "https://www.raylib.com/")
+    (license license:zlib)))