summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-07-06 18:36:26 +0000
committerLeo Famulari <leo@famulari.name>2021-07-06 19:13:16 -0400
commit37ce56af34c5067edae77e172e3d8409321650d8 (patch)
tree3579d1a8076fc7ef8623f2a5bdbc9981b1d86e56 /gnu
parent0913843efc6531bdbed414321ad418a092ced7f6 (diff)
downloadguix-37ce56af34c5067edae77e172e3d8409321650d8.tar.gz
gnu: Add MLT 7.
* gnu/packages/video.scm (mlt): New variable.
(mlt-6): Inherit from above.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm60
1 files changed, 40 insertions, 20 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index de69ff1c8b..5503bebe17 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3014,29 +3014,22 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
        "This package provides a command-line interface for Twitch.tv")
       (license license:gpl3+))))
 
-(define-public mlt-6
+(define-public mlt
   (package
     (name "mlt")
-    (version "6.26.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/mltframework/mlt")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1gz79xvs5jrzqhwhfk0dqdd3xiavnjp4q957h7nb02rij32byb39"))))
+    (version "7.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mltframework/mlt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13c5miph9jjbz69dhy0zvbkk5zbb05dr3vraaci0d5fdbrlhyscf"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ;no tests
-       #:configure-flags
-       (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
-                            (assoc-ref %build-inputs "gtk+")
-                            "/lib/gtk-2.0/include")
-             (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
-                            (assoc-ref %build-inputs "glib")
-                            "/lib/glib-2.0/include"))
+     `(#:tests? #f ;requires "Kwalify"
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'override-LDFLAGS
@@ -3052,7 +3045,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
        ("fftw" ,fftw)
        ("frei0r-plugins" ,frei0r-plugins)
        ("gdk-pixbuf" ,gdk-pixbuf)
-       ("gtk+" ,gtk+-2)
+       ("gtk+" ,gtk+)
        ("libxml2" ,libxml2)
        ("jack" ,jack-1)
        ("ladspa" ,ladspa)
@@ -3081,6 +3074,33 @@ functionality of the system is provided via an assortment of ready to use
 tools, XML authoring components, and an extensible plug-in based API.")
     (license license:lgpl2.1+)))
 
+(define-public mlt-6
+  (package
+    (inherit mlt)
+    (name "mlt")
+    (version "6.26.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mltframework/mlt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1gz79xvs5jrzqhwhfk0dqdd3xiavnjp4q957h7nb02rij32byb39"))))
+    (arguments
+     `(#:configure-flags
+       (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
+                            (assoc-ref %build-inputs "gtk+")
+                             "/lib/gtk-2.0/include")
+             (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
+                            (assoc-ref %build-inputs "glib")
+                            "/lib/glib-2.0/include"))
+       ,@(package-arguments mlt)))
+    (inputs
+     `(("gtk+", gtk+-2)
+       ,@(alist-delete "gtk+" (package-inputs mlt))))))
+
 (define-public v4l-utils
   (package
     (name "v4l-utils")