summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 17:10:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 17:10:53 +0100
commit3942bf5e4ca175313102a24570212aadc3d1337e (patch)
tree332931aa433fd19f41004a55ff729b1e20a3a4cd /gnu
parent51df43408b040effb83526e1342ce336e6ee90e4 (diff)
downloadguix-3942bf5e4ca175313102a24570212aadc3d1337e.tar.gz
gnu: Add r-apcluster.
* gnu/packages/cran.scm (r-apcluster): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82a39da6a9..4baf0307ba 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11663,3 +11663,28 @@ network.")
     (description
      "This package provides various R programming tools for model fitting.")
     (license license:gpl2)))
+
+(define-public r-apcluster
+  (package
+    (name "r-apcluster")
+    (version "1.4.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "apcluster" version))
+       (sha256
+        (base32
+         "188hdfmwjjx3aic599nwmkzjqm9j9jighi5bly6qd43c1vj6ih2s"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrix" ,r-matrix)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/web/packages/apcluster/")
+    (synopsis "Affinity propagation clustering")
+    (description
+     "This package implements affinity propagation clustering introduced by
+Frey and Dueck (2007).  The package further provides leveraged affinity
+propagation and an algorithm for exemplar-based agglomerative clustering that
+can also be used to join clusters obtained from affinity propagation.  Various
+plotting functions are available for analyzing clustering results.")
+    (license license:gpl2+)))