summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-03 14:50:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:36:12 +0300
commit3daa7f6277f78b953a4bcc667fbf92e5482b3551 (patch)
tree821166f19d56fc73bdf749a8934ebebfe895b1e1 /gnu
parentccee38a10cf845237f9606af2d8b6e858e86c082 (diff)
downloadguix-3daa7f6277f78b953a4bcc667fbf92e5482b3551.tar.gz
gnu: Add rust-termtree-0.4.
* gnu/packages/crates-io.scm (rust-termtree-0.4): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 89ec63fe49..0091816b7b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -70416,6 +70416,23 @@ bindings are a small wrapper around the raw C functions, which converts integer
 return values to @code{std::io::Result} to indicate success or failure.")
     (license license:expat)))
 
+(define-public rust-termtree-0.4
+  (package
+    (name "rust-termtree")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "termtree" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0xkal5l2r3r9p9j90x35qy4npbdwxz4gskvbijs6msymaangas9k"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/rust-cli/termtree")
+    (synopsis "Visualize tree-like data on the command-line")
+    (description "Visualize tree-like data on the command-line.")
+    (license license:expat)))
+
 (define-public rust-test-assembler-0.1
   (package
     (name "rust-test-assembler")