summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:44:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:55 +0200
commit3db87db2d85ef180a4901606780ce68b17e222e8 (patch)
tree4fe13ccc827f6ccfbc5c857613d0305d471d5341 /gnu
parente025003e0f3b03b30efbf41c24b3e3ad7617b97a (diff)
downloadguix-3db87db2d85ef180a4901606780ce68b17e222e8.tar.gz
gnu: Add texlive-bidi-atbegshi.
* gnu/packages/tex.scm (texlive-bidi-atbegshi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2a89510150..28248f2cdf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -812,6 +812,27 @@ bidirectional texts with plain TeX and LaTeX.  The package includes
 adaptations for use with many other commonly-used packages.")
     (license license:lppl1.3+)))
 
+(define-public texlive-bidi-atbegshi
+  (package
+    (name "texlive-bidi-atbegshi")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/xelatex/bidi-atbegshi/"
+                   "tex/xelatex/bidi-atbegshi/")
+             (base32
+              "08gawna9hf5p3rn0v5qzszk61zqknixafvh6d2x37x960x493gn7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/bidi-atbegshi")
+    (synopsis "Bidi-aware shipout macros")
+    (description
+     "The package adds some commands to the @code{atbegshi} package for proper
+placement of background material in the left and right corners of the output
+page, in both LTR and RTL modes.  The package only works with @code{xelatex}
+format and should be loaded before the @code{bidi} package.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-libkpathsea
   (package/inherit texlive-bin
     (name "texlive-libkpathsea")