summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-05-06 10:20:32 -0400
committerMark H Weaver <mhw@netris.org>2019-05-06 10:33:18 -0400
commit3e605b6998b6b5d748835bae6994a0ff01b0bd18 (patch)
tree05358ca60daaf0feef618eadd31129c6844a5d66 /gnu
parentebff346945af58ee152ac7668e4456cc7d0433a9 (diff)
downloadguix-3e605b6998b6b5d748835bae6994a0ff01b0bd18.tar.gz
gnu: icecat-source: Make sure 'makeicecat' is the right version.
* gnu/packages/gnuzilla.scm (icecat-source): Check to make sure the
value of FFMAJOR in the 'makeicecat' script matches the major version
of IceCat being generated.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 87e51931c6..c9b14cfd16 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -528,7 +528,13 @@ from forcing GEXP-PROMISE."
                           "-p1" "--input" #+makeicecat-patch)
                   (patch-shebang "makeicecat")
                   (substitute* "makeicecat"
-                    (("^FFMAJOR=.*")
+                    (("^FFMAJOR=(.*)" all ffmajor)
+                     (unless (string=? #$major-version
+                                       (string-trim-both ffmajor))
+                       ;; The makeicecat script cannot be expected to work
+                       ;; properly on a different version of Firefox, even if
+                       ;; no errors occur during execution.
+                       (error "makeicecat major version mismatch"))
                      (string-append "FFMAJOR=" #$major-version "\n"))
                     (("^FFMINOR=.*")
                      (string-append "FFMINOR=" #$minor-version "\n"))