summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-08-06 16:44:43 +0100
committer宋文武 <iyzsong@member.fsf.org>2023-08-13 15:42:50 +0800
commit419b675d777323e85ba595b4f216a796871f00ee (patch)
tree170f175933d0417993856cdcb8200dcdc39b3e85 /gnu
parent400cd0870bb240ac774427592b6c9a4a4970c256 (diff)
downloadguix-419b675d777323e85ba595b4f216a796871f00ee.tar.gz
gnu: mympd: Enable tests.
* gnu/packages/mpd.scm (mympd)[arguments]: Enable tests.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mpd.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 862d4f737f..a399c1eab1 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -629,8 +629,16 @@ mpdevil loads all tags and covers on demand.")
     (arguments
      (list
       #:configure-flags
-      #~(list "-DMYMPD_STRIP_BINARY=OFF")  ; handled by 'strip phase
-      #:tests? #f)) ; no test target
+      #~(list "-DMYMPD_BUILD_TESTING=ON"
+              ;; Handled by 'strip' phase.
+              "-DMYMPD_STRIP_BINARY=OFF")
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                ;; The following test requires network connectivity.
+                (invoke "ctest" "--exclude-regex" "test_http_client")))))))
     (native-inputs (list jq perl pkg-config))
     (inputs (list flac libid3tag lua openssl pcre2))
     (home-page "https://jcorporation.github.io/")