summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-06 23:57:38 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-06 23:58:54 +0100
commit41d07f5e98ffeb7230bff71a760177cbc5d8f6e7 (patch)
tree6e521d20b0fec56524885ec4a24993a708b32b4b /gnu
parent3c1f0e3b996ff80aa6fffd572cdee6a95c2b97a5 (diff)
downloadguix-41d07f5e98ffeb7230bff71a760177cbc5d8f6e7.tar.gz
gnu: Add xf86-video-modesetting.
* gnu/packages/xorg.scm (xf86-video-modesetting): New variable.
* gnu/services/xorg.scm (xorg-start-command)[xserver.conf]: Add
  ModulePath line for XF86-VIDEO-MODESETTING, commented out.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm28
-rw-r--r--gnu/services/xorg.scm2
2 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 99ff2cff32..219d063d54 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2731,6 +2731,34 @@ autotools system.")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
+(define-public xf86-video-modesetting
+  (package
+    (name "xf86-video-modesetting")
+    (version "0.9.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+              "mirror://xorg/individual/driver/xf86-video-modesetting-"
+              version ".tar.bz2"))
+        (sha256
+         (base32
+           "0p6pjn5bnd2wr3lmas4b12zcq12d9ilvssga93fzlg90fdahikwh"))))
+    (build-system gnu-build-system)
+    (inputs `(;; FIXME: This is a libdrm version incompatible with that of
+              ;; MESA, which xorg-server uses.  Therefore, using this driver
+              ;; leads to "unresolved symbol drmModeSetCursor2".
+              ("libdrm" ,libdrm)
+              ("xf86driproto" ,xf86driproto)
+              ("libx11" ,libx11)
+              ("xorg-server" ,xorg-server)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "\"Modesetting\" graphics driver for the Xorg server")
+    (description
+     "This is a generic \"modesetting\" video driver, that relies on the Linux
+kernel mode setting (KMS).")
+    (license license:x11)))
 
 (define-public xf86-video-neomagic
   (package
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index a1cfe1f3ab..39eaeee0a4 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -52,6 +52,8 @@ Section \"Files\"
   FontPath \"" font-adobe75dpi "/share/fonts/X11/75dpi\"
   ModulePath \"" xf86-video-vesa "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-fbdev "/lib/xorg/modules/drivers\"
+# FIXME: Commented out due to libdrm incompatibility.
+#  ModulePath \"" xf86-video-modesetting "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-cirrus "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-intel "/lib/xorg/modules/drivers\"
   ModulePath \"" xf86-video-mach64 "/lib/xorg/modules/drivers\"