summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2023-07-18 13:26:50 +0200
committerLudovic Courtès <ludo@gnu.org>2023-07-18 14:06:50 +0200
commit437687b7151f722bb76b2e9550910e0611572d10 (patch)
tree319b16b153b176e1dac1da4ddcab7076b8f309a9 /gnu
parentb910dedff0e5296b116f7f95fc201206958b0b2f (diff)
downloadguix-437687b7151f722bb76b2e9550910e0611572d10.tar.gz
gnu: insight-toolkit: Remove input labels and use gexps.
* gnu/packages/image-processing.scm (insight-toolkit)[arguments]: Use
gexps.
[inputs]: Remove labels.
(insight-toolkit-4)[arguments]: Use gexps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image-processing.scm74
1 files changed, 36 insertions, 38 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index a6af0ce626..6a72209f96 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1279,39 +1279,38 @@ libraries designed for computer vision research and implementation.")
         (base32 "0bs63mk4q8jmx38f031jy5w5n9yy5ng9x8ijwinvjyvas8cichqi"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f            ; tests require network access and external data
-       #:configure-flags
-       '("-DITK_USE_GPU=ON"
-         "-DITK_USE_SYSTEM_LIBRARIES=ON"
-         "-DITK_USE_SYSTEM_GOOGLETEST=ON"
-         "-DITK_BUILD_SHARED=ON"
-         ;; This prevents "GTest::GTest" from being added to the ITK_LIBRARIES
-         ;; variable in the installed CMake files.  This is necessary as other
-         ;; packages using insight-toolkit could not be configured otherwise.
-         "-DGTEST_ROOT=gtest"
-         "-DCMAKE_CXX_STANDARD=17")
+     (list #:tests? #f ; tests require network access and external data
+           #:configure-flags #~'("-DITK_USE_GPU=ON"
+                                 "-DITK_USE_SYSTEM_LIBRARIES=ON"
+                                 "-DITK_USE_SYSTEM_GOOGLETEST=ON"
+                                 "-DITK_BUILD_SHARED=ON"
+                                 ;; This prevents "GTest::GTest" from being added to the ITK_LIBRARIES
+                                 ;; variable in the installed CMake files.  This is necessary as other
+                                 ;; packages using insight-toolkit could not be configured otherwise.
+                                 "-DGTEST_ROOT=gtest"
+                                 "-DCMAKE_CXX_STANDARD=17")
 
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'do-not-tune
-           (lambda _
-             (substitute* "CMake/ITKSetStandardCompilerFlags.cmake"
-               (("-mtune=native") "")))))))
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'do-not-tune
+                          (lambda _
+                            (substitute* "CMake/ITKSetStandardCompilerFlags.cmake"
+                              (("-mtune=native")
+                               "")))))))
     (inputs
-     `(("eigen" ,eigen)
-       ("expat" ,expat)
-       ("fftw" ,fftw)
-       ("fftwf" ,fftwf)
-       ("hdf5" ,hdf5)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libpng" ,libpng)
-       ("libtiff" ,libtiff)
-       ("mesa" ,mesa-opencl)
-       ("perl" ,perl)
-       ("python" ,python)
-       ("tbb" ,tbb)
-       ("vxl" ,vxl-1)
-       ("zlib" ,zlib)))
+     (list eigen
+           expat
+           fftw
+           fftwf
+           hdf5
+           libjpeg-turbo
+           libpng
+           libtiff
+           mesa-opencl
+           perl
+           python
+           tbb
+           vxl-1
+           zlib))
     (native-inputs
      (list googletest pkg-config))
     (home-page "https://github.com/InsightSoftwareConsortium/ITK/")
@@ -1338,13 +1337,12 @@ combine the information contained in both.")
        (sha256
         (base32 "19cgfpd63gqrvc3m27m394gy2d7w79g5y6lvznb5qqr49lihbgns"))))
     (arguments
-     `(#:tests? #f            ; tests require network access and external data
-       #:configure-flags
-       '("-DITKV3_COMPATIBILITY=ON"     ; needed for itk-snap
-         "-DITK_USE_GPU=ON"
-         "-DITK_USE_SYSTEM_LIBRARIES=ON"
-         "-DITK_USE_SYSTEM_GOOGLETEST=ON"
-         "-DITK_USE_SYSTEM_VXL=ON")))))
+     (list #:tests? #f ; tests require network access and external data
+           #:configure-flags #~'("-DITKV3_COMPATIBILITY=ON" ; needed for itk-snap
+                                 "-DITK_USE_GPU=ON"
+                                 "-DITK_USE_SYSTEM_LIBRARIES=ON"
+                                 "-DITK_USE_SYSTEM_GOOGLETEST=ON"
+                                 "-DITK_USE_SYSTEM_VXL=ON")))))
 
 (define-public insight-toolkit-4.12
   (package (inherit insight-toolkit-4)