summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-30 17:18:44 -0500
committerMark H Weaver <mhw@netris.org>2015-01-31 00:06:20 -0500
commit43cc5c5e616888610aa9842e3f065b1c90e044ca (patch)
tree197153149f6d1bd2c7a0e22989a7568c28f103fe /gnu
parent28bda60251e20a1f1870a7cce61c388bc2a2a180 (diff)
downloadguix-43cc5c5e616888610aa9842e3f065b1c90e044ca.tar.gz
gnu: icecat: Use gstreamer-1.0 and enable webrtc.
* gnu/packages/gnuzilla.scm (icecat)[inputs]: Use latest gstreamer and
  gst-plugins-base.
  [arguments]: Remove "--disable-webrtc" and add "--enable-gstreamer=1.0" to
  configure flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnuzilla.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 862dfe1a31..5e54a2d921 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -229,8 +229,8 @@ standards.")
        ("dbus" ,dbus)
        ("dbus-glib" ,dbus-glib)
        ("glib" ,glib)
-       ("gstreamer" ,gstreamer-0.10)
-       ("gst-plugins-base" ,gst-plugins-base-0.10)
+       ("gstreamer" ,gstreamer)
+       ("gst-plugins-base" ,gst-plugins-base)
        ("gtk+" ,gtk+-2)
        ("pango" ,pango)
        ("freetype" ,freetype)
@@ -259,7 +259,7 @@ standards.")
                            "--disable-debug-symbols"
 
                            "--enable-pulseaudio"
-                           "--disable-webrtc"     ; webrtc fails to build
+                           "--enable-gstreamer=1.0"
 
                            "--with-system-zlib"
                            "--with-system-bz2"    ; FIXME: not used