summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-24 12:09:10 +0200
committerMarius Bakke <marius@gnu.org>2021-06-13 01:00:46 +0200
commit44775a7e8ddceb074efa7935e773c6aa0da88cca (patch)
tree850f2101ef24f4361d9c4582b892d5b8183afc9e /gnu
parent4796b5d6d18dcc0f1b6c8e134977ebdb575c5741 (diff)
downloadguix-44775a7e8ddceb074efa7935e773c6aa0da88cca.tar.gz
gnu: python-attrs: Update to 21.2.0.
* gnu/packages/python-xyz.scm (python-attrs): Update to 21.2.0.
[native-inputs]: Remove PYTHON-SPHINX and PYTHON-ZOPE-INTERFACE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6451638afa..f95a24d7cb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16870,13 +16870,13 @@ and bit flag values.")
 (define-public python-attrs
   (package
     (name "python-attrs")
-    (version "20.3.0")
+    (version "21.2.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "attrs" version))
               (sha256
                (base32
-                "007pchhxk2nh6m2rgflkkij9xjwysq3fl7xr72cy8i4pw76s6al3"))))
+                "1yzmwi5d197p0qhl7rl4xi9q1w8mk9i3zn6hrl22knbcrb1slspg"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -16888,9 +16888,7 @@ and bit flag values.")
        ("python-hypothesis" ,python-hypothesis)
        ("python-pympler" ,python-pympler)
        ("python-pytest" ,python-pytest)
-       ("python-six" ,python-six)
-       ("python-sphinx" ,python-sphinx)
-       ("python-zope-interface" ,python-zope-interface)))
+       ("python-six" ,python-six)))
     (home-page "https://github.com/python-attrs/attrs/")
     (synopsis "Attributes without boilerplate")
     (description "@code{attrs} is a Python package with class decorators that